Schlagwort-Archive: Ubuntu

Es gibt keine öffentlichen Schlüssel für die folgenden Schlüssel-IDs

Gestern habe ich in meiner Ubuntu-Installation folgenden Fehler bekommen:

Auf der Kommandozeile dann folgenden Befehl eingeben:

Danach wurde der Schlüssel aktualisiert und nun funktioniert wieder alles bestens.

How to install the Nextcloud Desktop Client at Ubuntu

Derzeit ist es sehr schwer einen Client für Linux/Ubuntu zu finden, der direkt aus Paketquellen zu installieren geht. Nachfolgend habe ich eine Doku dazu gefunden:

https://help.nextcloud.com/t/linux-distribution-packages-for-the-desktop-clients-help-out/2538/34#post_35

https://www.c-rieger.de/how-to-install-nextcloud-desktop-client-for-ubuntu/

http://repo.morph027.de/nextcloud-client.php

Ich habe mich dann aber für das folgende Repository entschieden:
https://launchpad.net/~nextcloud-devs/+archive/ubuntu/client
Ubuntu hat jetzt ein offizielles Repository zur Verfügung gestellt.

Repository einbinden und NextCloud-Client installieren:

Wenn beim o.g. Befehl („add-apt-repository“) folgender Fehler kommt, dann muss das Paket „software-properties-common“ nachinstalliert werden:

Configure Ubuntu Linux to use Smartcard Authentication within the Firefox-Browser

Einrichtung

Dieser Artikel erklärt kurz, wie man mit dem Firefox unter Ubuntu die Zertifikatsbasierte  Client Authentifizierung umsetzen kann.

Zuerst die folgenden Pakete installieren:

Als nächstes muss man den Firefox schließen, die SmartCard einlegen und wieder starten.
Jetzt im Firefox unter: Menü > Bearbeiten > Einstellungen > Erweitert > Zertifikate den Punkt „Kryptographie-Module“ auswählen und den angeschlossenen SmartCard-Reader per „Laden“ hinzufügen.

SmartCard im Firefox einrichten

SmartCard im Firefox einrichten

Dabei sollte bereits (falls benötigt) die Signatur-PIN auf der Smartcard freigeschaltet sein, da der Firefox diese auslesen und benutzen will.

Debugging

Den pcscd kann man auch per „Hand“ im Debug-Modus starten. Dazu einfach mit

in einem Terminal starten.
Dieser läuft dann im Vordergrund und gibt die Meldungen aus, wenn die Karte eingesteckt wird und welche Aktionen gerade passieren.

Links

hilfreiche Informationen fanden sich für mich hier: CommonAccessCard

Ubuntu Updates – BADSIG X0xxxx Error

Manchmal kommt folgende Fehlermeldung beim Update mittel aptitude/synaptic/apt-get usw.

Im Normalfall kann man die Signer mit gpg-Mitteln importieren, aber wenn man einen Proxy benötigt um ins Internet zu kommen, ist das nicht so einfach möglich. Bei mir schlug der gpg Befehl zum Importieren der Keys leider fehl, weil der Keyserver nicht erreicht werden konnte.

Auch die Angabe des Proxys mit Angabe User/Password half bei diesem Problem nicht weiter.

Die Lösung brachte schlußendlich folgende Befehlsabfolge:

Vielen Dank an: chr.istoph, der Blog für den „sachdienlichen“ Hinweis.

Danach funktionierte das Update wieder einwandfrei.